Trustly Service Update-> Service Degradation - 2021-01-13
Incident Report for PXP Financial
Resolved
Please be informed that the issue reported earlier has been resolved.

The issue was caused due to technical difficulties on a third party provider.

The service has been restored to its full functionality.
Posted Jan 13, 2021 - 15:46 UTC
Investigating
Please be advised that we are currently experiencing a partial degradation of service which affects a fraction of customers deposits.

We are monitoring the situation and will advise you when the service is restored.
Posted Jan 13, 2021 - 12:38 UTC
This incident affected: Local Payment Method(s).