Trustly Service Update-> Service Degradation - 2021-05-03
Incident Report for PXP Financial
Resolved
Please be informed that the service degradation reported earlier is now resolved.

We continue monitoring the situation and we will inform you in case of further disturbances.
Posted May 03, 2021 - 12:46 UTC
Investigating
Please be advised that we are currently experiencing a degradation of service which affects deposits.

We are currently working on it and will advise you as soon as the service is restored.
Posted May 03, 2021 - 12:24 UTC
This incident affected: Local Payment Method(s).