Trustly Service Update-> Swedbank - Sweden + Baltics - 2021-01-22
Incident Report for PXP Financial
Resolved
Please be informed that the issue reported earlier with Swedbank in Sweden and Baltics has been resolved.

The service has been restored to its full functionality on all countries.
Posted Jan 22, 2021 - 11:28 UTC
Investigating
Please be advised that we are currently experiencing a degradation of service for Swedbank in Sweden and in the Baltics

The issue is seems to be caused due to technical difficulties on bank's systems.

We are monitoring the situation and will advise you when the service is restored.
Posted Jan 22, 2021 - 10:02 UTC
This incident affected: Local Payment Method(s).