Trustly Service Update-> Germany - Sparkasse - 2021-04-15
Incident Report for PXP Financial
Resolved
Please be informed that the issue reported earlier with Sparkasse in Germany has been resolved.

The service has been restored to its full functionality.
Posted Apr 15, 2021 - 21:34 UTC
Investigating
Please be advised that we are currently experiencing a partial degradation of service for one of our banks - Sparkasse Bank in Germany.

The issue is affecting some of the customer deposits from this bank.

We are monitoring the situation and will advise you when the service is restored.
Posted Apr 15, 2021 - 20:59 UTC
This incident affected: Local Payment Method(s).