Trustly Service Update-> Sweden - Swedbank - 2021-04-19
Incident Report for PXP Financial
Resolved
Please be informed that the issue reported earlier with Swedbank in Sweden has been resolved.

The service has been restored to its full functionality.
Posted Apr 19, 2021 - 04:25 UTC
Investigating
Please be advised that Trustly is currently experiencing a degradation of service for one of their banks - Swedbank in Sweden.

The issue is affecting customer deposits from this bank.

We are monitoring the situation and will advise you when the service is restored.
Posted Apr 18, 2021 - 23:48 UTC
This incident affected: Local Payment Method(s).