Trustly Service Update-> Sweden - SEB - 2021-04-18
Incident Report for PXP Financial
Resolved
Please be informed that the issue reported earlier with SEB Bank in Sweden has been resolved.

The service has been restored to its full functionality.
Posted Apr 18, 2021 - 04:37 UTC
Investigating
Please be advised that we are currently experiencing a degradation of service for one of our banks - SEB Bank in Sweden.

The issue is affecting customer deposits from this bank.

We are monitoring the situation and will advise you when the service is restored.
Posted Apr 18, 2021 - 04:06 UTC
This incident affected: Local Payment Method(s).