Trustly Service Update > Payout Delays - Sweden - Nordea - 2021-04-16
Incident Report for PXP Financial
Resolved
Please be informed that the issue reported earlier with regards to payout delays for Nordea account holders in Sweden has been resolved.

Customer payouts are being processed as per our regular service.

We would appreciate it if you could pass this information on to those concerned within your organisation.
Posted Apr 18, 2021 - 07:19 UTC
Investigating
We would like to inform you that we are experiencing processing delays for payouts to Nordea bank account holders in Sweden.

The issue is due to technical difficulties on the bank's end.

We are monitoring the situation and will advise you when the service is restored to its regular functionality.
Posted Apr 16, 2021 - 20:00 UTC
This incident affected: Local Payment Method(s).