MisterCashDeposit Down
Incident Report for PXP Financial
Resolved
Incident Reference:
255800
Payment Provider:
WorldPay
Payment Method:
MisterCashDeposit
Incident Description:
The Approval rate is back to normal since 4/19/2021 01:00 UTC. We are continuing to monitor the transactions for stability.
Start Time
22:23
End Time
01:00

For further information please contact the PXP Support Team on +44 (0) 844 209 4372 or support@pxpfinancial.com or click here to create a ticket.
Posted Apr 19, 2021 - 01:44 UTC
Update
We are continuing to investigate this issue.
Posted Apr 19, 2021 - 01:27 UTC
Investigating
Incident Reference:
255800
Payment Provider:
WorldPay
Payment Method:
MisterCashDeposit
Incident Description:
Provider has informed about a Maintenance @ MisterCash/Bancontact till 19/04/2021 04:00 UTC. Customers transactions would fail during the maintenance window.
Impact:
High
Start Time
22:23
End Time
04:00

For further information please contact the PXP Support Team on +44 (0) 844 209 4372 or support@pxpfinancial.com or click here to create a ticket.
Posted Apr 19, 2021 - 00:36 UTC
This incident affected: Local Payment Method(s).