ANYpay Elavon Settlement Delay - 01/04/2024
Incident Report for PXP Financial
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 10:33 UTC
Identified
Incident Reference:
973264
Acquirer
Elavon
Incident Description:
There is a settlement delay for Elavon transactions dated 31/03/2024, due to a submission failure.
Impact:
Possible 24 hour settlement delay for transactions taken on 31st March 2024.

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxpfinancial.com or click here to create a ticket.
Posted Apr 02, 2024 - 10:20 UTC
This incident affected: ANYpay (Settlement).