The approval rate is back to normal since 10/28/2024 2:35:58 PM UTC. PXP Tech Team will continue to monitor the transactions for stability. PXP systems are operating normally.
Posted Oct 29, 2024 - 07:29 UTC
Monitoring
We continue to notice the approval rates have improved since 14:36 UTC. PXP Systems are operating normally. Updates will be provided as more information becomes available.
Posted Oct 28, 2024 - 16:35 UTC
Investigating
Incident Reference:
1039194
Payment Method:
VISA payments
Incident Description:
We are noticing VISA payments intermittently failing in User Authentication Error since 12:18 UTC. PXP technical team is coordinating with the required teams for resolution. PXP systems are operating normally. Updates will be provided as more information becomes available.
Impact:
HIGH
Start Time
28/10/2024 12:18
For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxpfinancial.com or click here to create a ticket.