Klarna - Delay in settlements
Incident Report for PXP Financial
Resolved
We would like to inform you that we are now able to view today's Klarna batches.
Posted Mar 09, 2024 - 20:36 UTC
Identified
We would like to inform you that Klarna is currently facing delays in merchant settlements and is actively working on resolving this issue.
Posted Mar 09, 2024 - 18:11 UTC
Investigating
Incident Reference:
960344
Payment Provider:
Klarna
Payment Method:
Transactions through provider Klarna
Incident Description:
This is to inform you that there will be delay in Klarna settlements for Today i.e., 09/03/2023, as the settlement files have not been received from the provider Klarna. We are checking with the Provider for the Settlement files. Updates will be provided as more information becomes available.
Impact:
HIGH
Start Time
09/03/2024 11:15

For further information please contact the PXP Support Team on +44 (0) 203 885 0598 or support@pxpfinancial.com or click here to create a ticket.
Posted Mar 09, 2024 - 17:18 UTC
This incident affected: Local Payment Method(s).